易语言逐字分割中文英文文本字符串,不会乱码!

有时我们需要逐字分割中英文混合文本,直接拆分的话,可能会因为中文英文字节占用长度不同而出现乱码,这个时候我们就需要使用额外的逐字分割函数才能得到正确的结果,提供易语言源码如下,需要自取:

.版本 2
.子程序 逐字分割
.参数 欲取的内容, 文本型, , 欲取的内容
.参数 返回的数组, 文本型, 数组, 存储数组变量
.局部变量 n, 整数型
.局部变量 代码, 整数型
.局部变量 临时, 文本型
.局部变量 i, 整数型
.局部变量 返回文本, 文本型
清除数组 (返回的数组)
n = 1
欲取的内容 = 到半角 (欲取的内容)
.判断循环首 (n ≤ 取文本长度 (欲取的内容))
    临时 = 取文本中间 (欲取的内容, n, 1)
    .如果真 (取代码 (临时, ) < 0)
        临时 = 取文本中间 (欲取的内容, n, 2)
        n = n + 1
    .如果真结束
    加入成员 (返回的数组, 临时)
    n = n + 1
.判断循环尾 ()

聚慧网 » 易语言逐字分割中文英文文本字符串,不会乱码!

提供最优质的资源集合

立即查看 了解详情